Added users to EaaSI hosted, but they no longer "appear"

Deployment: Are you using the hosted EaaSI service, or a local node? HOSTED

EaaSI Version: This corresponds to the release branch/installer version used to deploy your instance. This information should be available in the Manage Node menu, if accessible. 1.10.0

Browser: The name and version of the browser you are using to access the EaaSI UI, if applicable
Chrome Version 90.0.4430.93 (Official Build) (x86_64) also tried on Firefox 88.0.1 (64-bit)
Description: Please describe your issue in as much detail as possible, including name + ID of any relevant environments, software or content. You can also attach screenshots or relevant error report files.

Logged in ok, used Manage Node, Mange user to Create a handful of users - seemed to work, I could see them in a grid view. Now see no users and searching for users doesn’t appear to execute. Do I add them again or?

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome?

I expected the users I created to get a notice, login, and go about the cabin but I think they went into the bermuda triangle.

Urgency: If possible, please give an indication of how urgently the issue needs to be addressed - is there a timeline or deadline (e.g. upcoming demo, researcher request, etc.) that EaaSI support staff should be aware of?. Can this be fixed in a day or two ?

Log file:

eaas-error-report-145-1105.gpg (107.5 KB)

Hi @nkmeyers! Can you please just quickly confirm whether logging out and then immediately logging in again (in the same browser) allows you to see the list of users again? (Or whether the list has reappeared at any point in the past few days?)

We think this may be a problem that occurs when a tab is left open and inactive for a certain amount of time and the user’s access token refreshes while the application is still open. We’ll investigate that behavior in general but are not certain if it is causing this particular issue.

Logging out and back in does not make the users reappear, users pane is still blank. ¯_(ツ)_/¯

Also tried it on another computer and its browser both of which I never use and had never gone to before . Users Pane was empty on there too.

Still can’t see node users 2021-06-02T04:00:00Z .

Thanks @nkmeyers! We think we narrowed this down. You somehow lost your “admin” permissions in Keycloak, the identity management provider EaaSI’s now using on the back-end. That would explain both the errors trying to add new users and not being able to retrieve and see the other users in the node.

Oleg has reassigned your “admin” role, can you please check again and confirm if you can see Notre Dame node users now?

Hurray that worked,

1 Like

hoorah! let us know if it happens again, that may help us narrow down why it happened in the first place