Deleted resources still searchable (and selectable)

I added a software resource, deleted it, and then added it back with the same name.

I then went to start an emulation environment. When I went to search for my software, it came up in the search results twice. I tried both, but neither of them ended up working. (The session failed to start.)

Is there a period of time when deleted names are taken out of the search results? If I upload this again, should I give it a completely new name?


More information! Even after deleting both resources from My Resources, they still show up in that list. I think that’s probably why I’m seeing the weird behavior that I am; they’re not really fully deleting.

(no worries about where the post goes, @dianne.dietrich! I have indeed moved this thread to the Support section so that it can be referred to later, but it is simple to do that on my end)

We’re investigating this and I will get back ASAP. We have had caching concerns before so it may be something with the Software resource’s metadata still showing in the UI though the resource itself is gone - I’ll check in that 1) Software resources are being deleted properly and 2) the front-end’s cache is resetting immediately to reflect the deletion. Can I confirm that you are trying to delete as an “Admin”-level user?

In the meantime - giving a new name to the resource can help with troubleshooting a problem like this, yes, though you can also get the resource UUID by clicking on the title and going to the Software resource’s Details page. That can help confirm whether you are truly looking at the same resource or not. (If you receive an error trying to go to the Details page, that would be further confirmation that the resource itself is gone and the card still being available is the problem/artifact)

I have good news and bad news! It turns out that I was set as a “Configuration User”. I turned myself into an Admin user but the behavior still remained. Anything deleted still shows up in my list of Imported Resources.

I get a blank page, though, when I try to look at the Content Resource Detail for any of the items I tried to delete, if that helps with troubleshooting. (Though, to be fair, I am getting a blank page for those resources I haven’t tried to delete.)

thanks @dianne.dietrich! still working on this. but helpful to know for sure re: the user roles, and yes, to clarify: Software resources have Details pages, Content resources do not, that is expected. Apologies if there is confusion because your Content is software (small “s”). That resource type distinction can matter.

Content resource Details pages were removed because there was basically nothing editable or functional on those pages. (Software resources are currently review-only, but they have Details pages because they will have functional metadata like “allowed number of instances/simultaneous sessions” or “this Software is a bootable OS/installer” in the near future) This does raise the concern that, for troubleshooting purposes, we may want the Content resource UUID displayed somewhere more prominently, to match Environment and Software resources. I’ll raise this as a design/UX question. Out of curiosity - how did you even get to a (blank) Content Details page?

Hi, @ethan.gates!

The resouces in question here are actually “Software Resources” (and not “Content Resources”). (In retrospect, I should have uploaded them as Content Resources, but alas, I did not.)

So if I click on one of the deleted Software Resources, the right-hand contextual Actions Menu comes up and I click on the “View Details” option and then I get an essentially blank page.

If I try to start an Environment with any of these (now three) deleted resources, I get a pop-up that says, “An Error Has Occurred” with a full stacktrace. It’s a long message but I can paste in the pertinent bits if you needed.

1 Like

got it! thanks for clarifying. I can replicate in the hosted service myself, so no need to provide your stacktrace, and we will continue to work on a fix :+1:

Thanks so much!

I can delete Content Resources and they disappear from the list in “My Resources”, so it looks like this issue is only constrained to the Software resources. (Apologies if this was already known.)

I’m seeing this too. And since I can’t delete anything, the list of Software Resources in my Imported resources list is extremely long, cluttered with imported images that are broken and useless. And it only shows 10 of them max, and if I click “See All Software Resources” it doesn’t do anything, so I can’t get to anything past 10.
I end up having to use the search bar, but that doesn’t work well because it searches everything instead of just the Imported resources and I have to look through pages of stuff to find what I want.

Thank you for confirming the same behavior on your end @hhsu11. As a follow-up I’ve also noticed that the option to filter on “Software” resources using the Resource Type option in the Refine Your Results bar seems to be missing even when there are definitely/obviously Software resources available. So there is clearly an issue with the storage of Software resources, we’re investigating and will look to provide a fix for everyone ASAP.

I have a sense that this new issue I’m about to describe is related to the original one I reported (in this thread). I am no longer able to add Private Software Resources (that I have not deleted, I’m 99% sure of that) to an emulation environment to run. I can add Private Content Resources to environments, however.

Is anybody else seeing this, too?

I am now finding that content resources (which I was previously able to delete) are now un-deleteable, but even after “deletion” I can still use them in emulation projects. Is anyone else seeing this behavior as well?

hey @dianne.dietrich - something that Oleg found (in response back to the start of this thread) is that there appear to be inconsistent paths in the web client code depending on where you select the “Delete” action. In other words, selecting a Content resource and clicking “Delete” from the overview of resource cards on the Explore Resources page actually triggers different code than selecting “Delete” on the Imported Resource tab of My Resources, for example.

Weve been working to stamp out the inconsistencies and as of last week in our latest test deployment, deletion was finally working as expected from each possible path for all Private resources (Content and Software and Environments). Oleg is now working through some deployment issues and we’re working toward updates on the hosted service asap.

To clarify though - are you saying that Content you had previously deleted re-appeared, or just that new attempts at deleting a Content resource fail, and the resource remains present and able to add to an Emulation Project? If the latter, have you tried selecting the Delete action from the Imported Resource tab of the My Resources page? I found that seemed to more consistently function as expected than from the Explore Resources page.


Thank you for the explanation! I did some more poking around, and this is really interesting. When I go to My ResourcesImported Resources, I’m noticing a few things.

  1. The Refine Your Resources only has a filter for Content, even though there are Software Resources that are appearing in the list. (Those are Software Resources I have previously deleted, though.)
  2. There are 6 content resources showing up, and when I delete one, it does actually disappear from the list now. (Woo!)

(This was originally going to be a longer list, but then I noticed the content resources are deleting, so hooray!)