Installing Postscript driver

This page of the EaaSI handbook says " Please consult the Software Help section of the EaaSI Community Forum if needing assistance in this area for the Environment or legacy operating system of your choice."

I am working to enable Postscript in my most stable environments, Windows 98 SE and MacOS9.0.4.

Can you help with some pointers on how to make this happen?


Hi @Cynde_Moya, indeed, I can post some tips/instructions here to replicate what we’ve set up in the U.S. EaaSI Network:

Windows 98 SE

For any Windows 9x systems, I highly recommend installing the “Adobe Universal PostScript Windows Driver” (v1.06), which was released by Adobe in 2002 and allows EaaSI users to set up pretty much any “PostScript” printer model as a virtual printer compatible with the EaaS “Environment can print” feature.

Luckily, this driver was captured by an Internet Archive crawl of from 2002, so you can still download the appropriate files straight from “source”:

After running the installer for the Universal PostScript Windows Driver, you can use the Start Menu to navigate to Settings → Printers and then use the “Add Printer” wizard to set up a local virtual printer. I’ll include some screenshots of the process below; you should be able to select pretty much any PostScript-compatible make and model, but we have generally had good luck with selecting HP models (looking for “PS” in the name of the model obviously is a big hint/clue/help that a model is PostScript-compatible without having to go comb through old printer documentation)

Assuming “Environment Can Print” has already been enabled in the Environment settings, you can use the “Print test page?” prompt from the very last step of the process to immediately test whether the driver and printer setup has worked: after selecting “Yes” for printing a test page, after a moment or two the “Download Print Jobs” button at the top of the Emulation Access page should become selectable (it’s usually grayed-out until a PDF/download job is detected) and offer a PDF (“document-1.pdf”, the document # will iterate/add if more print jobs are made within the same emulation session) for the EaaSI user to download via their browser.

Save the Environment and from then on, users should be able to “Download Print Jobs” by printing to that same virtual printer that you set up within emulation.

Apologies for the delay re: Mac OS 9.0.4; I went to check/confirm how this configuration was accomplished in our own Mac 8 + 9 base environments and realized that I could not actually confirm that “Download Print Jobs” worked with them.

After clarifying with OpenSLX, unfortunately the “Download Print Jobs” feature only works in QEMU-based environments. It relies on QEMU’s functionality for creating a virtual character device to pipe print jobs out of the running environment and convert to PDFs for the EaaS/EaaSI user to download.

I have updated the Handbook everywhere the Download Print Jobs feature is mentioned and added an explicit warning under the Emulator Limitations. I’ll do some digging/checking to see if print-to-PDF can be accomplished with e.g. Mac OS 9.2.1 in QEMU instead.


I followed these instructions and they unfold more or less as described.

However, in the EaaSI Client, environment “Windows 98 SE - 124G HDD” the “Download Print Jobs” button never highlights for the install “print test page” or subsequent “print test page” commands.

I re-did the install of the Universal Printer Driver in the Demo Client, and there, the first “print test page” during the install of the Universal Printer Driver did print a downloadable test page. However, subsequent attepts with both “print test page” from printer properties, and printing a WordPad document, did not show up in the “Download print jobs” dialog.

I also looked at the EaaSI Client and Demo Client in, trying Windows 98 SE - Base V2 (HP Color LaserJet PS printer installed, QEMU v2.12) and Windows 95c (OCR2.5) Base V2 (HP LaserJet 4/4M Plus PS installed, QEMU Latest), and neither of those highlight the Download Print Jobs button with “Print Test Page.”

Thanks for your help troubleshooting this.


Hi @Cynde_Moya, couple separate issues here: since the Download Print Jobs setup does work with the Environment (at least once) in the Demo Client in your local/AusEaaSI setup, the “Download Print Jobs” button never highlighting in the EaaSI Client sounds like a bug. I’ll file a ticket, see if I can reproduce, and we’ll get back in touch if more detail is needed.

I will also take a closer look at the hosted service issues you are reporting and get back to you.