Windows XP 32-Bit with QEMU - No Bootable Device

Deployment: Self-hosted

EaaSI Version (if self-hosting): 2021.10

Browser: Chrome

Description: When I attempt to run the Windows XP 32 Bit + Sibelius Student Edition 3.50 environment, which I have saved locally from the network, it’s stalling out on the boot screen:

Wondering if it might be an issue with Sibelius or something else about this specific environment, I also tried running the Windows XP 32 Bit + Microsoft Office Professional 2003 environment and got stalled on the same boot screen.

This seems like it might be related to Eric’s issue, but I have not run into this issue with other QEMU environments (Windows 95 + FileMaker Pro 3.0v1 is running fine).

Urgency: This week, if possible.

Hey - hmm, this is similar to the issue that you linked but I don’t think quite the same. We would expect this sort of issue if there was an issue in the server configuration preventing the underlying disk image for the Windows XP 32 Bit + Sibelius Student Edition 3.50 environment from copying correctly between the network (Yale’s node, in this case) to your node; but to my understanding that would prevent any environments from copying and running correctly, so it’s odd that some are working and some are not.

I double-checked that saving Windows XP 32 Bit + Sibelius Student Edition 3.50 to worked and ran as expected, so it should not be an issue with the environment itself; and if I’m calculating right saving those XP environments should only involve copying less than 3 GB of data each at the most so a timeout issue with those environments in particular seems unlikely.

apologies to have to tag @oooleg in again but we’re probably going to need to take a direct look at the server logs again

Hi! According to the log, the environment references an image consisting of 3 layers and one of them is missing. Looking through older logs, it seems, that replication of that environment was triggered on 2023-02-24 and aborted a bit later, because of a server-restart. This resulted in an incomplete image with a missing layer.

I have started a download of the missing image layer manually and will follow up here, once it completes. It will take about 1.5h at current download rate.

Thanks so much! Let us know if we can provide any more info.

Missing image layer has been downloaded successfully. Just checked, the environment is usable now., please keep in mind, that your host VM does not have any KVM configured. Because of that, performance of emulated Windows XP might be slow. See also the official documentation for more information.

Thank you so much @oooleg!! Really appreciate you resolving this so quickly. And thanks for the note about KVM configuration too - we are just using this for a limited amount of testing and demos, so performance didn’t seem as important when we first set it up, but we may have to reconsider it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.