EaaSI Demo Lite and importing MacOS9

Deployment: Are you using the hosted EaaSI service, or a local node?
Local Node
EaaSI Version: This corresponds to the release branch/installer version used to deploy your instance. This information should be available in the Manage Node menu, if accessible
Build: 4b4d29910860f5031683fd350fece7726b0c0606
UI Build: cb82b3d4b399d1ff155748bf4c0d743a062cd655
on Windows 10

Browser: The name and version of the browser you are using to access the EaaSI UI, if applicable
Firefox

Description: Please describe your issue in as much detail as possible, including name + ID of any relevant environments, software or content. You can also attach screenshots or relevant error report files.

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome?

Urgency: If possible, please give an indication of how urgently the issue needs to be addressed - is there a timeline or deadline (e.g. upcoming demo, researcher request, etc.) that EaaSI support staff should be aware of?
Not Urgent

I downloaded and followed the instructions to install EaaSI_Demo_Lite on Windows 10. This seemed successful, and I have the familiar Legacy Interface.

Following the Special Considerations for Mac/Apple Environments, I then tried to install MacOS9 using the Generic Sheepshaver Template.

I used my own newworld86.rom image, and a MacOS9.raw image in the Import Environment workflow.

The gears spin, and then complete. But instead of a working emulator, I get a page that reads something like “The Emulator has stopped.”

Any tips for more success?

Hi @cyn0matic! I think the issue here is with the emulator version and template used. Since those EaaSI Demo releases were made, the EaaS team re-tinkered the way emulators are configured with environments, such that the emulator containers tagged “latest” are likely incompatible with the Demo Client/UI.

Please try to import an older Sheepshaver container from the GitLab registry and then try again - I would suggest one from 2019, e.g. the one tagged git-cddb8fc17fa16b422d8fa5e0136e0fccf5d8692f

Example emulator import config in the Demo Lite interface:

The goal should be to get a template on the Import and Create Environment menus called “Apple PPC (OS 8.x-9.x)”. Then repeat with the same ROM and image import steps you tried before.

The emulator templates labelled “Generic” - “Generic Sheepshaver Template”, “Generic QEMU x86 Template” are the newer templates and will not work. I will try to find appropriate place(s) in the Handbook to document this accordingly!