Error Running any Imported Software or Objects

Deployment: Are you using the hosted EaaSI service, or a local node?
Local Node
EaaSI Version: This corresponds to the release branch/installer version used to deploy your instance. This information should be available in the Manage Node menu, if accessible
Application Version 1.8.17
Browser: The name and version of the browser you are using to access the EaaSI UI, if applicable
Firefox, though probably not applicable.

Description: Please describe your issue in as much detail as possible, including name + ID of any relevant environments, software or content. You can also attach screenshots or relevant error report files.

We were doing test imports for the 2019 Beta files. After importing the software, attempting to run it paired with the Windows 98 Test Env resulted in a error (attached log files).

We imported the Microsoft Encarta ISO and they produced the attached error log. If we paired the same environment with the same Encarta ISO imported from Yale it worked fine. I think there is an issue with our import process.

Similarly, we imported a private ISO for a Mac OS 9 instance, and it appears to have produced a similar error when we tried to run it with the “Add Software” option.

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome?

We expected in each case that the imported ISO would be present for inspection in the environment, but instead there was an error.

Urgency: If possible, please give an indication of how urgently the issue needs to be addressed - is there a timeline or deadline (e.g. upcoming demo, researcher request, etc.) that EaaSI support staff should be aware of?

I’m using this in coordination with both the University library and for active research with students currently, so not being able to import resources is preventing multiple research studies from proceeding. eaasi_error_1.log (86.6 KB) eaasi_error.log (11.4 KB)

The error occurs when loading the “run emulator” either from the “add software” option in the explore resources tab or when selecting an environment and running it in “rendering environments” from the object’s page.

Hi @ekaltman - this may seem an odd request, but can you try logging out and then logging back in immediately before attempting to run the object(s) in emulation? (via either “Add Software” or “rendering environments” options)

There is an error message::WHERE parameter "userID" has invalid "undefined" value in the logs you attached, which is a sign of a persistent bug in the v2020.03 EaaSI client’s user management. It seems to be gone in our current dev branches (with overhauled user + resource management) but until a new release the simplest work-around is unfortunately just to log out and log in again.

Just did with rendering environments, same error, will try the run emulation.

Same error on run emulation. Is there an issue with the import not detecting the import user? I can run software objects from other institutions but not those I uploaded.

Hmm, possibly @ekaltman. Does this happen with resources imported as both Software and Content, or just Software?

This is happening with both software and content. The software is just a test using the Microsoft Encarta / Golf training examples. The content is imaged media from CI’s collections. Both the Encarta and Golf that were already present in the system (from you all I think) work fine.

Is there an elegant way to restart the whole system? Maybe that will help with this. I can re-deploy with the update script but I don’t know if that will fix anything.

Thanks for the follow-up, Eric. I think a graceful restart of the front-end/UI components could be attempted by restarting its various Docker containers (there are several, so something along the lines of $ docker ps -q | xargs docker restart or similar should get them all, assuming there is no other application running on the server that this would interfere with)

Alternatively, I’ll flag this thread from the old Google Groups list which may have some less-graceful solutions, including, yes, re-seeding the client’s database via the upgrade script in the eaasi-installer repository:

And, should all else fail, if time does not allow us a better solution here, I’ll just mention that one can essentially roll back to the demo client/UI by commenting out everything in the portal section of your eaasi.yaml and re-deploying. That will get you essentially a v2019.11 EaaSI installation, with demo client credentials as specified in the ui section of the config yaml.

will that UI reduction delete the current contents of the eaasi environments? I’m fine with giving this a shot, since getting the software and object imports working will be necessary for me before the end of May. Also, I’m assuming this bug is now gone in the newer versions of the system? If there’s some way to manually modify the database for the missing values I’m comfortable taking more of a look into the internals