Error running environments in EaaSI Hosted Service


EaaSI Version: 2021.10

Browser: Firefox 115.7.0 and Chrome

When I go to either “Explore Resources” or “Emulation Project” and click “Run in Emulator” to launch an environment, I receive the following error message: “An Error Has Occurred,” with options to download front-end and back-end logs or close. My front-end log is attached. I am unable to download the back-end log – clicking the button takes me to a blank browser tab. If I try clicking “Close,” the error pop-up reappears in an infinite loop, and the only way to escape is to close the browser tab.
I have tried launching multiple environment resources that leverage different emulators and include different operating systems, and each time I receive the same error.

The error has been replicated by other users at Yale (today) and the University of Alberta (noticed yesterday).

Urgency: This issue is blocking the work of several students and staff members at multiple institutions, so speedy diagnosis and resolution would be appreciated.

eaasi-frontend-error-report_2024-02-13.txt (58.2 KB)

@ekaltman and @claireafox tagging you on this issue in case you’d like to report additional info. Thanks for noticing this issue, Eric, and apologies to you and the students for the inconvenience.

Update: this issue seems to be resolved, thanks to speedy help from @oooleg.
Cause: the issue seems to have been caused by reaching storage capacity limitations on
Resolution: storage capacity was increased and temporary files were cleaned up.

More specifically, we’ve run into the following related issues:

One of our internal non-fixable dependency might leave a lot of garbage in some cases, filling out temporary disk space. A workaround for this behavior has already been implemented and will be included in the next release.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.