Unable to build or save emulation project with Mac OSX 10.2 Jaguar environment

Deployment: Hosted
EaaSI Version: 2021.07
Browser: Chrome Version 92.0.4515.131

Description: I have been unable to get an emulation project to save imported software to it via multiple pathways. This issue might have similarities to what Eric reported in this ticket: Error Running any Imported Software or Objects

*Are you able to reproduce the issue or did it happen once?
I was able to reproduce the issue:

After successfully importing an ISO for Vectorworks Learning Series disc and saving it as Software, I also saved the Mac OSX 10.2 Jaguar environment locally so I could try to build a basic environment that would have this software saved to it.

After successful import, I went to create an Emulation Project. I was able to successfully add the Mac OSX Jaguar to the Project. However, when I went to add resources to the project, they would not save to the Emulation Project.

I first tried this with my imported software via going to “My Resources” and then “Imported Resources”, selecting it, and selecting “Add to Emulation Project” from the menu. However, this seemed to fail silently, as I was returned to the Emulation Project page with no resource saved.

After multiple failed attempts, I also tried to add an existing Resource to the project (via the “Explore Resources” menu and chose Microsoft Money, and selecting “Add to Emulation Project” from the menu. This also failed and returned me to an Emulation Project (still with a base environment of Mac OSX 10.2) with no resources saved.

At this point I logged out and then back in again to try a reset, but was met with the same issues outlined above.

Today I went a different route and instead, from the detailed Environment page for Mac OSX 10.2 Jaguar (where metadata and history are presented as menu options), I chose the “Actions” menu, and “Add Software”. I was able to select the VW11_LearningSeries software, and the environment started up just fine, with the software clearly showing in the environment. I was able to run the software and take actions from the menu, run learning modules, etc.

I shut down the system as needed, and then chose to “Save Environment”. I chose “Revision” and supplied a new name and description of the change made. After clicking “Save”, I did not see any errors or messages, but now cannot find the saved environment within the hosted instance.

Thanks for any help you can give!

Urgency: Not very urgent, but it is important that saving environments and building environments works for further testing. This environment of Mac OSX 10.2 is definitely needed for some versions of software we hope to run