EaaSI Demo Lite and Windows 98

Deployment: Are you using the hosted EaaSI service, or a local node?
Local EaaSI Demo Lite
Windows 10

EaaSI Version: This corresponds to the release branch/installer version used to deploy your instance. This information should be available in the Manage Node menu, if accessible
Build: 4b4d29910860f5031683fd350fece7726b0c0606
UI Build: cb82b3d4b399d1ff155748bf4c0d743a062cd655

Browser: The name and version of the browser you are using to access the EaaSI UI, if applicable
Firefox

Description: Please describe your issue in as much detail as possible, including name + ID of any relevant environments, software or content. You can also attach screenshots or relevant error report files.

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome?

Urgency: If possible, please give an indication of how urgently the issue needs to be addressed - is there a timeline or deadline (e.g. upcoming demo, researcher request, etc.) that EaaSI support staff should be aware of?
Not urgent

Installed EaaSI_Demo_Lite apparently successfully.

Using QEMU Latest, i have tried to install Windows 98 SE.

It will use the boot disk in drive a> to fdisk drive c>, but then ESC + Restart, it looks to boot off of the hard drive, where there is nothing yet. I can’t get it to reboot off of a> and then do the next Format a: step.

I have tried importing the boot floppy + the install CD-ROM as a set, but the emulator doesn’t like that. It also won’t start the install directly from the CD-ROM by itself.

Any tips? How else can I get Windows 98 SE running on EaaSI Demo Lite for Windows 10?

Hi @cyn0matic, a couple tips:

  1. EaaS/EaaSI can not handle mixed-media type objects, so for Windows 98 installations or similar, the boot floppy and CD-ROM installer must be imported as separate Software resources.

  2. Does setting an explicit -boot a flag to the QEMU configuration in the Native Config section when going through the Create Environment workflow help at all? Hopefully, this would direct the emulator to boot from the floppy drive when the guest system is restarted, allowing you to run format c:

  3. Following on from both those points, in order to run a mixed floppy + CD-ROM install, once the C: system drive is formatted, you’re going to need to copy over the contents of the boot floppy from A: to C:, then save the Environment. That should allow you to then attach the non-bootable Win98 CD-ROM installer to the saved Environment, and QEMU will boot off the bootable floppy contents now on the C: drive and let you start/run the installation from the ISO in the D: drive.

I will try to test directly, especially to clarify and solve point #2.

Follow up - with a -boot a flag set I am able to get back to the DOS prompt and the boot floppy after partitioning with fdisk and rebooting, but am discovering issues with the boot floppy not having the FORMAT.COM or XCOPY utilities. FORMAT.COM is contained in the compressed “EBD.CAB” cabinet file, but for some reason refuses to extract with the EXTRACT.EXE utility, even though there is still free space on the A: drive/boot floppy and it isn’t write-protected. But, that step’s a bit academic anyway - without a COPY or XCOPY on the boot floppy, we won’t be able to do the copy over to the system/C: drive as I described above anyway…

Since we can’t mount the boot floppy and the installer ISO at the same time, this all seems to depend greatly on what particular Windows boot floppy you’re using and what’s on it. I will report back if I find one with FORMAT and XCOPY. Another option here would be to just start with a MS-DOS install and run the Windows98 SE install from CD-ROM on top of that…

Hi Cynde,
Not sure if you managed to solve this issue, but I have a working version of 98SE going on my local EaaSI Demo Lite. I followed these steps - (25) Windows 98 on VirtualBox - How to do it properly. 32bit Graphics and ACPI. NEW Version 6 - YouTube
As Ethan points out, the way I succeeded by saving the environment mid-way through. i also found forcing ACPI support really helps with the mouse pointer for EaaSI. It locks the mouse pointer so that it tracks really accurately. There is a part two to that video.

1 Like

Tim, you are the EaaSI Whisperer!

2 Likes

Today I certainly felt like I was the EaaSI Whisperer as I managed to load a version of IBM OS/2 Warp 4 into EaaS.

There were over 110 floppy disk images to load to get it working and on a couple of occasions it froze, but thankfully recovered with a bit of Ctrl+Alt+Del lol.

Additionally, the disk labels were terrible, and at times ambiguous. The version I had was from WinWorld.

As a reward to bring me back to earth, I attempted another try of creating a Mac based environment. No dice, so my whispering mustn’t be something Mac understands…

1 Like

Thank you for the tip about ACPI support @tim.mifsud! I will have to do some investigation to see if that is enabled in some of our existing environments and if it could improve mouse tracking.

I have tried OS/2 install before (we have a boot floppy + CD-ROM installer in Yale’s holdings) but the installer swaps back and forth between the two media even more often than the Win98 process, so I’ve never managed it even with formatting the system drive, copying over the floppy contents and saving the Environment in EaaSI mid-way. You are a brave person to get through the floppy-only install!!!