PPC setup not working in AusEaaSI

Deployment: AusEaaSI at playitagain.aarnet.edu.au

Browser: *Google Chrome Latest

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome?

This issue reproduces

Urgency: If possible, please give an indication of how urgently the issue needs to be addressed - is there a timeline or deadline (e.g. upcoming demo, researcher request, etc.) that EaaSI support staff should be aware of?

Trying to get environments set up for AusEaaSI rollout, this is interfering with having good BASE environments for them.

Using: AusEaaSI playitagain.aarnet.edu.au

When trying to create a Macintosh System 9.1.X - 10.4 (PPC) environment, instead of starting up, I get a yellow screen, which reads:

Welcome to OpenBIOS v1.1 built on Feb 22 2018 07:53
Trying cd:,:tbxi…
MacOS: unable to find a usable NVRAM partition - using offset 0x1400
MacOS: Boot Failure! (0xF3C481F6)
MacOS: unable to find an interrupt controller node.
0 >

This is using an image of MacOS9.2.2 imaged in my lab, along with a blank hard drive disk image 10GB_MAC from Blank hard drive disk images (100MB HFS up to 30GB HFS+) - Macintosh Repository

Is there a better way to create my own new PPC Mac environment?


In the hosted.eaasi.cloud node is an excellent Mac OS 9.2.1 PPC environment with the QEMU v 2.12 invocation:

-M mac99 -m 512 -device sungem -prom-env “boot-args=-v” -prom-env “auto-boot?=true” -prom-env “vga-ndrv?=true” -usb -device usb-mouse -device usb-kbd -g 1024x768x32 -boot c

I have tried this invocation in the playitagain.aarnet.edu.au AusEaaSI node, and it does start up ready to install, but it does not point to the hard disk drive, so there is nowhere for the CD to install to. I have imported a 10GB_MAC hard disk image obtained from Macintosh Repository into the /admin interface screen, but QEMU doesn’t seem to see it when starting the emulator. When trying to add the switch to the QEMU invocaton -hda 10GB_MAC, the environment throws an error.

Also, the default QEMU invocation for PPC Mac environments is only: -net nic,model=sungem , which does not start up and emulation session beyond the yellow OpenBIOS error listed above.

SO: I think that a different QEMU invocation could start up this PPC emulation, but I’m not sure what to try next.

hi @Cynde_Moya, if I’m understanding correctly, you found a way around the first OpenBIOS error (where it looks like QEMU is not booting the 9.2.2 installation CD properly) using the -M mac99 -m 512 -device sungem -prom-env “boot-args=-v” -prom-env “auto-boot?=true” -prom-env “vga-ndrv?=true” -usb -device usb-mouse -device usb-kbd -g 1024x768x32 -boot c QEMU configuration, which at least got you in to the bootable CD and run the installer - but now the installer does not see the blank hard disk drive image you acquired and imported from Macintosh Repository, so the installer program on the CD sees nowhere to install MacOS to, correct?

just to confirm, I believe I see the Macintosh Repository page/downloads you are referring to here:

first question: what drive configuration are you using to run both the installation CD image and the blank hard disk drive image at the same time?

second question/thought: I see two blank 10GB downloads, are you using the one formatted HFS or HFS Plus? (technically I think OS 9.x could be installed on HFS but was intended for HFS Plus and maybe that is causing issues for the installer, I’m not sure if a late version like 9.2.2 demanded HFS Plus)

if you are using the HFS Plus one and that’s still not working, possibly try using the EaaS Demo UI workflow for creating a blank disk image (under Images → Create New Image, specify desired size in MB so e.g. 10000 MB for a roughly 10 GB image) and then use the 9.2.2 installation CD that is successfully booting to try formatting and partitioning the completely blank drive with HFS Plus yourself (I think the “Drive Setup” utility was standard on OS 9 installation discs, should be somewhere on the CD?) rather than using Macintosh Repository’s pre-formatted one. if Drive Setup still does not see the blank hard disk image/drive at all, then the issue is definitely somewhere in the EaaS and QEMU drive configuration, not with the OS 9 installer…

Hi Ethan
That worked, there is a “Drive Setup” utility on the CD which worked to initialize the hard disk. Thank you!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.