QEMU-based MacOS 9.2.1+ operating systems have no sound, audio not supported (reopened)

Deployment: Self-hosted on GCP (https://playitagain.aarnet.edu.au/)

EaaSI Version (if self-hosting): 2021.10

Browser: All

Description:
See QEMU-based MacOS 9.2.1+ operating systems have no sound, audio not supported - EaaSI Support Center - EaaSI Community Forum.

Cynde and I have tried importing the Screamer-enabled emulator with no success. The ppc-screamer qemu emulator is the one provided by Raphael (registry.gitlab.com/emulation-as-a-service/emulators/qemu-eaas:screamer), while the ppc-screamer-test one is a custom-built image for testing different configure options which is not guaranteed to work (alexip/qemu-eaas:screamer). Following some of the Rhizome instructions, we have been able to get the mouse working with MacOS 9.2.1 under qemu, but we have still no sound in either MacOS 9.2.1 or 10.4.1 when using a qemu screamer emulator.

The emulator current configuration is as follows:

-audiodev pa,id=pa,server=/emucon/data/sockets/pulse-iosocket -M mac99,via=pmu -m 512 -device sungem -prom-env “boot-args=-v” -prom-env “auto-boot?=true” -prom-env “vga-ndrv?=true” -usb -device usb-tablet -device usb-kbd -boot c

We have tried many different configure options on the qemu screamer image build, as well as different screamer branches on the mcayland/qemu: Official QEMU mirror (github.com) repo with no success. We are hoping that we are very close and that there is a simple solution available - maybe we don’t have the right emulator configuration options or something. Any assistance would be greatly appreciated if anyone has actually got sound working satisfactorily with MacOS 9/10 in EaaSI.

Urgency: Not urgent

I have also still not yet had success with importing the ppc-screamer image @rafaelgieschke provided on existing installs running v2021.10 (hosted.eaasi.cloud) - I can give a try with the latest EaaSI code we are preparing for upcoming release and see if it fares any differently, which might at least give a clearer picture of what and how much work yet has to be done to incorporate the approach taken at Rhizome into EaaSI.

Particularly from Rafael’s prior guidance I am noting:

because from past experience testing EaaSI deployments it seems like proper WebRTC and Xpra configuration can be finicky and possibly even silently fail - @alex-ip can you confirm those options appear by all accounts to be succesfully enabled on the environments you are trying with the screamer build, or is there any indication something might be off with those settings?

G’day @ethan.gates - I can confirm that both of those options are enabled and, besides sound, both MacOS environments appear to be working normally.

With my custom image build, I tried different qemu build configure options based on ones I saw in various instructions, but they either had no apparent effect or broke things. There were some other screamer branches in the mcayland/qemu repo, but I didn’t have any success with those, either.

I was hoping to hear from someone who has actually had the sound working with Screamer, but I will probably stop looking at this now at least until the new release is out.