**eaasi-installer not compatible with eaasi-ansible**

Deployment: eaasi-installer branch: ‘eaasi-release-2020.03’
EaaSI Version:

eaasi-installer ‘eaasi-release-2020.03’

image: “eaas/eaas-appserver:master”
ui: git_branch: “master”
eaas: git_branch: “master”
portal: git_branch: “master”

Browser: Not applicable

Description: eaasi-installer seems not to be compatible with ansible used in eaasi-ansible.
The script ./scripts/prepare.sh failed allways.
Had to cheat with adding several lines in ./eaas/ansible/docker/ansible/data/installer.sh:

#!/usr/bin/env sh

set -e # fail on error
set -x # print executed commands

sed -i -e ‘s/v3.10/latest-stable/g’ /etc/apk/repositories
apk update
apk add rust

install system deps

apk add --no-cache

install latest ansible + deps

apk add py3-pip
pip3 install -r py-deps.txt

remove dev packages

apk del gcc

Maybe subsequent issues will arise when running ./scripts/deploy.sh. Do know by now…

Urgency: eaasi-installer should be fixed at latest, when April-release is available

@nb_glur and I have been troubleshooting some problems with the Forum moderation settings in addition to this eaasi-installer issue, so just to copy some of that information here for others:

The alpine-fix patch for Ansible referenced in Deploy failing on cryptography build - #4 by oooleg seems to have solved the compatibility issue Stephan first mentioned. The install still failed initially, possibly because of the Ansible script edits/hacks he had already made above:

emil@emil-ubuntu:/opt/eaasi-installer/eaas/ansible$ git apply alpine-313.patch

warning: docker/alpine/Dockerfile ist vom Typ 100755, erwartete 100644

error: Anwendung des Patches fehlgeschlagen: docker/ansible/data/installer.sh:8

error: docker/ansible/data/installer.sh: Patch konnte nicht angewendet werden

warning: docker/ansible/data/py-deps.txt ist vom Typ 100755, erwartete 100644

I can not read the error above but I am not sure that we need to continue here - I think our recommendation would be to start with a clean eaasi-installer, apply the patch, then attempt the prepare.sh and deploy.sh scripts.

Yes, the above error is probably related to the modified installer.sh file. The patch should only be applied to the original file from the installer repository.

@nb_glur, please also keep in mind, that a specific installer version is only compatible with specific versions of EaaSI components, attempts to mix them arbitrarily will probably fail.

If I interpret it correctly, then you are trying to use the installer for v2020.03 but configured it to install latest (master) EaaSI components. Please always use the versions specified in the eaasi.yaml.template.

Thanks Oleg,
yes I am always interested in the latest more or less stable developments. So I took the latest version of the installer, and tried to use it for all master branches.
OK, I will keep in mind, that this might cause problems.
Anyway, my installing/building issues seemed not to be related to my mixing of components…

Many thanks and best regards

That should also work in general, but is not the case right now. Since the last release, we have implemented several internal changes, which require special configuration to work properly. The corresponding installer modifications are in development/testing and hence are not available publicly yet. Because of this, the current public installer is simply not able to set up the latest backend version correctly.

Thanks for the explanations Oleg.
So I wait for the installer to be updated as well.