Failure to successfully mount IMF CD-ROM

  • Deployment: Hosted

  • EaaSI Version: 1.10.0

  • Description: I’m attempting to create a new environment using an IMF CD-ROM. I’ve successfully imported IMF_GFS_HJ101.G682.1972-1989.iso. Object defined as .iso on import. When I use the emulation project feature to associate this object with environment “Windows XP + Adobe Acrobat 9.3” and run the environment the CD-ROM does not mount and I receive an error.

  • Expected vs Actual Outcome: Expected to see CD-ROM available and mounted in OS so I can begin the install. Instead when I try to open the dirve I get a “Windows cannot read from this disk. The disk might be corrupted or in a format not compatible with Windows”

  • Reproducibility: I’ve tried to replicate the issue with other ISOs from this collection and all objects report the same error when trying to mount. I’ve also tried to use the “change media” feature to select the disk. I’m successful in doing this but the ISOs will still not mount.

  • Urgency: Not urgent.

Hi @mgolson! Thanks for reporting, and for the screenshots! Your Emulation Project setup looks good. Unfortunately, I am unable to replicate this problem, even using the same “Windows XP Professional + Adobe Reader 9.3” environment and other sample ISO Content or Software resources.

Do you see the same behavior with this environment with an ISO that’s not from this collection? (Maybe something from the eaasi sample corpus linked in your pilot testing document?) Do these ISO images mount correctly outside of EaaSI? I want to try to eliminate again whether this is an issue with the emulation or with the disk images…

Hi Ethan, Thanks for looking into this. I just loaded a different ISO resource that I would want to install on the same Win XP and it mounted the .iso just fine and I was able to do the install. I was able to run all the tests from the protocol and I had no problem. Its snappy! The EaaSI team as really made some performance improvements.

For the IMF what is puzzling is that after the first couple of failures I picked one I knew ran in our own Stanford hosted EaaSI (mind you that is a very old version). It is actually the same .iso file so that I used in some demos so it use to work, which is why I’m asking if it could be more than an a bad .iso. I’ll see if Mark has anytime next week to run a few tests and see if it isn’t something I’m doing unawares.

best, Michael

Thanks Michael, that does help a lot to know that the same images worked before, so the issue must be somewhere on our end. As far as I’m aware nothing particularly changed about the way the system handles ISOs, so this is curious.

Two thoughts or troubleshooting steps to try:

  1. Do the ISOs mount correctly in any other environment?
  2. Was there any kind of warning or problem during import of the ISOs?