Disk images mount as raw .iso files

Deployment: Are you using the hosted EaaSI service, or a local node?
EaaSI Version: This corresponds to the release branch/installer version used to deploy your instance. This information should be available in the Manage Node menu, if accessible
Browser: The name and version of the browser you are using to access the EaaSI UI, if applicable
Safari 14.1.2

Description: Please describe your issue in as much detail as possible, including name + ID of any relevant environments, software or content. You can also attach screenshots or relevant error report files.
I have imported a number of disk images from CHM’s software collection. Some are .iso files, others are .img files. No matter what they are, when I try to use them with various Mac OS base images, they always appear as .iso files or .img files in the virtual CD-ROM drive, rather than mounting as disks in the floppy or CD-ROM drives. This happened with System 7.01 (IIci) in Basilisk, System 7.5 in Basilisk, and Mac OS 8.5 in Sheepsaver and Mac OS 9 in Sheepsaver.

The only except was a .iso of Myth II Soulblighter, which Mac OS 8.5 correctly identified as a disk and tried to mount, but not Mac OS 9.
However Mac OS 8.5 could not recognize the file system on the disk (which it should have as it’s a Mac game, unless this was the Windows version. I think it’s actually a hybrid CD-ROM, so perhaps it correctly recognized the Windows half of the disk but not the Mac half?). It asked to initialize the disk, which it can’t because the image is read only, and it will keep asking this until the virtual disk is ejected.

I am also having similar issues with my imported Windows disks also showing up as raw .iso files in Windows 95 base environments.

I even tried to import some images as Content instead, but with the same results.

Perhaps this could be an issue with the disk images themselves? Are these images not compatible with EaaSI or with these emulators? What needs to be done to the images to make them work?

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome?
Happens with almost all the disk images I’ve imported, all the time.
These disks should mount as disks in the OS.

Urgency: If possible, please give an indication of how urgently the issue needs to be addressed - is there a timeline or deadline (e.g. upcoming demo, researcher request, etc.) that EaaSI support staff should be aware of?
Not really urgent, but definitely a blocking issue.

Ack. Elena pointed out that I have to specify what type of format the images are when I import. The default is “File” so that’s why they all just appeared as files!
We can delete this thread now. : P

1 Like

Thanks for providing the update. Please let us know if specifying the format corrects the issue.


Just to confirm for anyone else who finds this thread - indeed, the “Physical Format” selection determines how EaaSI will attempt to mount the imported file in emulation:

  • .iso files should be imported as ISO
  • .img I will presume are floppy disk images, and should be imported as Floppy
  • arbitrary file sets can be imported with the “Files” type Physical Format, but what happens there is that EaaSI will package up those selected files into an ISO and attempt to mount in the virtual CDROM drive; so, yes, that would be the expected behavior for everything to show up in the emulator as an .iso!

Beyond that, Basilisk and Sheepshaver can also behave strangely when it comes to hybrid CD-ROMs, so do follow up if you continue to have problems after specifying the image format on import!

So, I have attempted to import these images as ISOs, Floppies, and Disks with varying results.

I’ve had the best success with .img files and some A.001 files as floppies, which mounted correctly in Basilisk in System 7.01 and 7.5. However in Sheepsaver the same A.001 files that worked in Basilisk, only one disk image out of 4 mounts, and it mounts twice.

With all of the .ISO images, trying to mount them as CD-ROMs ends up mounting them as Audio CDs. Now two of these ISOs are games, so it’s possible these were hybrid data/audio CDs. But I was getting this pretty consistently with all the ISOs, in both Basilisk and Sheepsaver. It’s hard to know if what I’m seeing is a bug or if these images really do contain audio tracks.

Trying to import them as Disk results in EaaSI not starting at all.
It fails with an error. (Stack trace is too long to include here)

Thanks @hhsu11 - I can investigate the issue with importing Disks myself.

(There is a pending update where stack traces will be offered as a text-file download rather than copy/paste - that will hopefully make those easier to provide, once we have a maintenance window to push that change)

It is possible, we need to create SheepShaver environments with a different Drive Configuration (under Details) to allow for mounting more floppies. Are you still using “Mac OS 8.5” and “Mac OS 9” to test the floppies? The double-mounting behavior is odd though - I will check with the devs.

Hybrid/mixed-mode CD-ROMs (with a data and audio track both present) can show up in Basilisk and SheepShaver as an “Audio CD” with one (non-functional) track. We’ve seen this before in EaaSI: Emulating Voyager disks, and as far as I’m aware it’s a limitation of ISO disk images vs the BIN/CUE format - which, unfortunately, default builds of SheepShaver (and EaaSI) do not support at this time. (As that other thread mentions, Geoffrey Brown created a fork of SheepShaver with BIN/CUE support for addressing Voyager Company discs, but, as I say, that build is not available to use in EaaSI at the moment)

Can you confirm that any ISO images mount properly for you in Basilisk and SheepShaver (for instance , this one from the EaaSI sample corpus? We could at least eliminate any more problems on the EaaSI side and try to focus on a work-around for the issue between ISOs and SheepShaver instead.

The Macintosh Mania ISO loads correctly in both Basilisk and Sheepsaver.
So perhaps I should wait for BIN/CUE support?

1 Like

@hhsu11 is there any chance you would be able to share one of your ISO images with me privately? (for testing purposes only, I would not upload into the hosted service or any other EaaSI instance or service myself)

I’ve added BIN/CUE support to our active Feature Requests and will make a note for us to try to add relevant SheepShaver builds as soon as possible, but I would still like to investigate if it is possible to find a work-around for what you already have.

I will ask Elena if she can share them with you.

After some more digging: I can clarify that the behavior where MacOS in SheepShaver or Basilisk shows a non-functional “Audio CD” actually doesn’t quite have anything to do with whether there are or were audio tracks on the disc, which was my mistaken assumption. This behavior is present in SheepShaver any time you try to load a cdrom image either:

  1. completely lacking an HFS filesystem
  2. a “raw” image without an accompanying CUE or TOC to point SheepShaver and MacOS specifically to the HFS track or partition (the raw image could either be from a “mixed-mode” disc with both data and audio tracks, or just a “hybrid” disc with one data track but multiple filesystems, e.g. HFS and ISO)

The first point seems extremely moot since you know from context these are for Mac. The second seems much more likely, but, yes, even if a CUE or TOC file was present we would still not be able to mount the disc in EaaSI properly until the direct BIN/CUE support is added.

However it may still be possible to run these discs in SheepShaver, though the approach would vary depending on mixed-mode vs. hybrid filesystem. It would be very helpful to know:

  • what program was used to image the CDROMs?
  • is it possible to run the “disktype” tool on the .ISO file and share the output? or are there any other log files from the imaging process available?

A raw “hybrid filesytem” ISO/HFS image (no audio tracks) can probably be loaded as a raw ISO into an Apple environment (e.g. import it as “Files” type rather than “ISO” in order to just shuttle the file into the emulated OS rather than trying to mount it directly) and mounted with an older MacOS utility like Toast (we have some old versions at Yale I am working to make available). A “mixed-mode” data + audio disc could possible be pre-processed to extract just the data portion, though that obviously may result in missing audio for the meantime.