"Change Resource Media" button grayed out (Windows 3)

Deployment: Hosted
EaaSI Version: Application Version 2021.07
Browser: Google Chrome (Version 94.0.4606.61 (Official Build) (64-bit))

Description: This is a follow-up to the workaround suggested in the closed “No content in optical drive (Windows 3)” thread. In the workaround suggested in that thread, users are supposed to use the “Change Resource Media” button in the running sessions to swap to the “0-empty” drive. However, for me and another pilot participant, the “Change Resource Media” button is grayed out and cannot be selected. The button is accessible for our node’s admin, Monique Lassere, and she is able to use the workaround. The public environment is Windows3.0 with Ami Pro1.2 + Ashbery Content, and we are trying to access .SAM files in the Windows 3 + Ami Pro environment.

Are you able to reproduce the issue or did it happen once? What steps can you take to repeat the issue? What did you expect to occur and what was the actual outcome? Yes. This happens every time I follow the steps described in the Hosted Emulation Services: Testing Protocol, Part I document and attempt to apply the workaround.

I expected to be able to click the “Change Resource Media” button and follow the rest of the instructions outlined in the workaround. The actual outcome is that I cannot use the workaround because I cannot select the grayed out button.

Urgency: This is time-limited to the Hosted Pilot project. We have been unable to complete the final steps of Testing Protocol, Part I, which involve using our local collection materials.

Hello @vmdowney! Apologies for not being able to respond until today.

I see the issue you are describing. In the short-term, this is my fault for not fully thinking through the work-around I gave to Monique - I should have added a step suggesting to copy the contents of the D: drive to the C: drive before saving the “Ami Pro 1.2 + Ashbery Content” environment (while the “Ashbery” Content resource is mounted in the original “Windows 3.0 + Ami Pro” environment, where the work-around is temporarily successful). That way the .SAM files would persist in the system drive rather than the buggy CD-ROM/D: drive. @monique_lassere could try this, it would unfortunately mean re-doing the “Ami Pro 1.2 + Ashbery Content” environment; I can seek assistance removing the existing public one from the service to reduce confusion.

In the longer term I need to coordinate with our devs and clarify whether the “Change Resource Media” button behavior is a bug or expected. I will return with updated information to this thread about that feature as soon as I can.

1 Like

Hey @ethan.gates, sorry for the delay–I was out for a bit. I can definitely try this today. And it’s no worry at all because I would prefer to recreate the environment (i need to change the title!). I’ll do this sometime today when I have a moment! Thanks so much.

1 Like

So, I’m doing this now and I see the “Delete” button available for this environment. Does that mean I can go ahead and delete it? :slight_smile:

Hi, there, Update: I created the new environment and even though I saved it it didn’t populate. I waited a bit to see if it popped up and it didn’t. I ended up creating another one and now understand that there must be a lag that wasn’t present before. Apologies. Will update when it populates. Thank you!

Hi, there @ethan.gates I still can’t see the environments I created last week. Thank you

Hey! So I am now able to see the environment(s) I created a couple of weeks ago, but now when I try to access the files, I get an “Application Execution Error: No association for this data file exists”. I get this even if I load the content into the CD-ROM/D: drive. I replicated this with all Windows 3.0 + Ami Pro environments. I have a demo today that I wanted to use with this set of content :slight_smile: but I’ll try and use a different use case! Thank you!

hi @monique_lassere! IIRC Windows 3.0 did not do very well in terms of automatically picking an application to open files with - you had to either manually associate the file with an application, or run the desired application first and then use its menu to open the desired file.

Could you try either:

  • running Ami Pro first (C:\AMIPRO\AMIPRO.EXE, I believe) and then using the “Open” workflow in its “File” menu to try one of the .DOC files
  • in the File Manager, with the desired file highlighted, as seen in your screenshot, open the “File” menu and pick the “Associate” option. This will let you type in the file path for the executable you want to launch the file with (again, in this case, C:\AMIPRO/AMIPRO.EXE), and from there you should be able to double-click on the file in File Manager to automatically open it as expected. I think there may be an option in the “Associate” menu to do the same for all files of that type/extension, so you could just do the association once with one .DOC and have it apply to all .DOC files, but I’ll have to double-check that.

Hey, @ethan.gates! Thanks so much for the quick reply.

#1 did not work, but then
#2 did work! and now #1 works.

Thank you!!